Enroll NowMinimum System Requirements

The VIITA website, and the included courses, are optimized for use on the Firefox browser. To take full advantage of the site, it is recommended to use Firefox, which can be downloaded here: http://www.mozilla.com.

In order to properly view the VIITA Course Content, please make sure that your computer has the minimum system requirements stated below:

Flash Player 6.0.79 or later (http://www.adobe.com/go/getflash) (Flash Player 7 or later recommended), and one of the following browsers (the stated version or later):

Windows: Internet Explorer 7, Firefox 2, Google Chrome, Safari 3, Opera 9.5, Netscape 7, AOL 8, CompuServe 7

Macintosh: Safari 3 and later, Firefox 1.x and later, Google Chrome

Linux: Firefox 1, Opera 9.5, Konqueror 3.3.1

Last modified: Monday, 9 March 2015, 1:19 PM
You are not logged in. (Log in)